Apple install day, Composite color with AppleTV

Yesterday was apple install day. Installed Leopard on a external drive attached to the mac mini as well as on my MBP. While waiting i also took the opportunity to have a second look at my AppleTV.

Leopard Install

Here are my (minor complaints) with Leopard installation:

  1. The various installation options ( e.g. archive and install etc. ) should be placed more prominently. They should have a separate screen and not be hidden behind an options button. I missed the options buttonwith my first install. (I know RTFM)
  2. While Archive & Install preserves the /Library/Frameworks (thought they would be cleansweeped) , /usr/local wasn’t (took my some time to find that this was the reson for Postgres not being available)
  3. Couldn’t find the burn driver CD from BootCamp Assistant ( Guess i have to google a bit)

Now i just have to find out how to:

  1. Make the Postgres user a restricted user that doesn’t show up at the login screen
  2. Find some decent fanless FW-800 3,5” drives for Time machine. Right G-Drives look like the thing to go for. Are there any alternatives?

AppleTV

While waiting for the backup and install procedures to complete , i finally found the time to have a second look at my AppleTV.

Since the end of June it is packed away and unused. The reason being, that i’m unable to hook it up to my flat screen TV, although that same TV works perfectly with the mac mini, our MBPs and an iBook, via DVI. Unfortunately, it’s not HDMI and has no component input. (Since the other macs work flawlessly via DVI, and the AppleTV works perfectly with other LCDs via DVI, i figured that it also should work with my TV. Although since i tried everything i could imagine, the best picture i got was unusable (see here).

So yesterday i decided to take the composite video approach. Having read about a composite color hack it thought it would be worth the time spending. To my surprise i learned that there is also a software only version available for enabling color composite video via this Wiki page on awkwardtv.org. This was definitely something to try.

So i (re-)figured how to ssh to my ATV, copied the files ansd to my astonishment, it worked. Unfortunately, running the commands in /etc/rc.local doesn’t work (see here) . So i’m going to try to put them into .bash_profile today.